
 

 

 

 

 

 

 

 

 

 

 

 

 

  

BIMCalc 
Quickstart 

Calcsoft BV 

Version 1.4 • 4 juni 2020 



 

  
  

4 juni 2020 • page ii / iii 20106_RAP_Quickstart_A_200604.docx 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Version Date Status 

1.4 June 2020 final 

   

 

  

Project : BIMCalc 

Onderdeel : Quickstart 

Opgesteld door : ir. A.S. Vonk MRICS (Arno) 

Gecontroleerd door : ir. D.D.D. van Laar (Djordy) 

Bestandsnaam : 20106_RAP_Quickstart_A_200604.docx 

Opdrachtgever : IGG Bouweconomie 

Contactpersoon : A.S.Vonk 

Versie : A,  

Datum : 4 juni 2020 

 
Calcsoft BV 

Prinses Catharina-Amaliastraat 32 www.calcsoft.nl  

2496 XD Den Haag bimcalc@igg.nl  

   

 



 

  
  

4 juni 2020 • page iii / iii 20106_RAP_Quickstart_A_200604.docx 

 

 

 

 

Index 
 

1. BIMCalc Trial Edition ...................................................................... 4 

2. BIMCalc main application layout .............................................. 5 

2.1. Application Menu Bar .................................................................................................. 6 

2.2. Project management ................................................................................................... 9 

2.3. Project Item Tree ......................................................................................................... 12 

2.4. IFC model element tree ............................................................................................ 12 

2.5. IFC model element table .......................................................................................... 13 

2.6. The Comparison element table.............................................................................. 16 

2.7. IFC Model element properties ............................................................................... 16 

2.8. Project remarks ............................................................................................................ 17 

2.9. 3D model viewer ......................................................................................................... 19 

3. BIMCalc main features ............................................................... 20 

3.1. IFC file importing and project management ..................................................... 20 

3.2. Area calculation ........................................................................................................... 20 

3.3. IFC model comparison .............................................................................................. 20 

 

  



 

  
  

4 juni 2020 • page 4 / 21 20106_RAP_Quickstart_A_200604.docx 

 

1. BIMCalc Trial Edition 
After installing and running BIMCalc, it will be started as a trial edition. The following dialog will be 

presented to you: 

 

 

 

The trial edition has the following limitations applied: 

• The trial version of BIMCalc allows the users to create projects, but only import 2 IFCs into one 

project. 

• The trial version of BIMCalc does not allow users to save created projects. 

• The trial version of BIMCalc does not allow to compare project files. 

• The trial version of BIMCalc can only be used for 15 days after first start. 

If you already have a BIMCalc license key, you can click the ‘I have a license’ link presented in blue 

to activate the product. You will be presented with the following dialog: 
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By typing in your activation key, BIMCalc will then check it’s validity and activate your product if the 

validation process is successful. You can then close the dialog and continue to use BIMCalc without 

the trial limitations. 

If you do not have a license key and just want to try out BIMCalc, you can close the trial edition dia-

log with the close dialog button on the top right. 

For simplicity stake, the quick-start guide will continue to use BIMCalc Trial Edition throughout the 

document. 

2. BIMCalc main application layout 
After closing the trial edition window or activating BIMCalc, you will be presented with the main 

layout of the application. The application consists of separate segments which implement different 

kind of features to work with the imported IFC models, but they are also linked together. The fol-

lowing image consists of an example of the application layout. Please note the counters which will 

be described throughout the quick-start guide. 

 

 

 

The counters represent the different segments of the main layout, in order they are: - 1. The hori-

zontal application menu bar - 2. The project management bar - 3. The project item tree - 4. The IFC 

model element tree - 5. The IFC model element table - 6. The Comparison element table - 7. The 

selected IFC model element properties - 8. Project remarks - 9. 3D model viewer 

file:///C:/Users/a.vonk/AppData/Local/Microsoft/Windows/INetCache/Content.Outlook/YQ063TKN/Quickstart.docx%23X15c7e4ed58e69328647c9f673be1d78fd6aebb1
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2.1. Application Menu Bar 

The application menu bar consists of the following menu items: 

1. File 

2. View 

3. Help 

Most of the menu items also have shortcuts. You can view the shortcut key for a menu item next to 

the menu item name. If there is no key combination after the menu item name, it does not have a 

shortcut. 

1.1 File -> New project 

This menu point allows you to create a new BIMCalc project. It’s functionality will be described later 

in the Project management section. 

1.2 File -> Open 

This menu point allows you to open up an existing BIMCalc project. It’s functionality will be de-

scribed later in the Project management section. 

1.3 File -> Open recent 

BIMCalc registers projects which have been recently opened. If you want to re-open a project which 

was recently opened by BIMCalc, you can use this menu point to instantly open up the recent pro-

ject. 

1.4 File -> Close project 

This menu point allows you to close an opened BIMCalc project. It’s functionality will be described 

later in the Project management section. 

1.5 File -> Save project 

This menu point allows you to save a BIMCalc project. It’s functionality will be described later in the 

Project management section. 

1.6 File -> Save project as 

This menu point allows you to save a BIMCalc project to a different location. Clicking this menu 

item while there is an opened project presents a file saving dialog to you where you can choose a 

new location to the project and will continue with the saving process described later in the project 

management section. 

1.7 File -> Autosave 

If you click this menu item, automatic project saving will be enabled in BIMCalc. This means that 

any change which affects the project will be instantly saved. Please note that turning this feature on 

while using BIMCalc Trial Edition will not save the project. 

1.8 File -> Settings 

Clicking this menu item will open up the Settings dialog of BIMCalc. 
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The settings dialog consists of the following two vertical tabs: 

1. General settings 

2. Language 

The first tab allows you to specify a username. This username will be used when you create remarks 

for a BIMCalc project item. 

The second tab allows you to specify the language of BIMCalc. Currently Dutch and English options 

are available. Please note that the application language will only be changed after you restart BIM-

Calc. 

Changes made to these settings can be confirmed with the ‘OK’ button on the bottom, while with 

‘Cancel’ you can close the dialog without changes made to BIMCalc. 

1.9 File -> Exit 

Clicking this menu point will close BIMCalc. If there is a currently opened BIMCalc project which has 

unsaved changes and you are using an activated product, the application will allow you to save the 

changes made to the project before closing (or discard them if needed). 

2.1 View -> Reset View 

BIMCalc opens IFC files at a certain position calculated based on the IFC file. The camera of the 3D 

model viewer can be freely moved around in many different ways, which is later on described in the 

3D model viewer section. If you would like to return the camera into this default opening position, 

you can use this menu point to do so. 

2.2 View -> Configure View 

BIMCalc is capable of rendering a large number of element types usually available in IFC models. 

However, in some cases, it might be optimal to turn off specific elements from rendering to boost 

the responsiveness and performance of the 3D model viewer (for example, turning off furniture be-

cause it is not used in any of the calculations we want to do with the IFC model). 

Clicking this menu point will present you with the following dialog, containing a tree-like structure: 
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On the left side of the name of the IFC element type is a checkbox which controls whether to ren-

der that specific IFC element in the 3D model viewer. On the right side of the name in parentheses, 

the number of elements can be seen in the currently opened 3D model, which helps you choose 

elements which are present in large numbers in the IFC. If the checkbox is in a checked state, the 

element will be rendered in the 3D model viewer. If its in an unchecked state, the element will not 

be rendered in the 3D model viewer. Clicking the ‘OK’ button on the bottom will save the changes 

to these elements, and refresh the 3D model viewer which now will use the new settings to render 

the model. Clicking the ‘Cancel’ button will close the dialog without changes. 

Use this menu point if you are having performance problems with your IFC model to optimize it’s 

rendering. Please note however, that a minor knowledge of the IFC protocol structure and naming 

convention is needed to fully operate this menu item. 

2.3 View -> Camera options 

The camera settings for the camera of the 3D model viewer can be found below the ‘Configure 

View’ menu point. These are toggle menu items which will modify the behavior of the camera. The 

menu items should be self explanatory. 

3.1 Help -> About 

Clicking the ‘About’ menu point will present you with a dia-

log containing general information about BIMCalc. Among 

the version number of BIMCalc (which can be useful to know 

for troubleshooting purposes), if you are using a trial edition 

of the product, the trial limitations are also present to you, 

and also a link is available to visit to purchase a license key. 

3.2 Help -> Activate BIMCalc 

If you are using a trial edition of the product, this menu point 

allows you to activate BIMCalc using a license key. If the acti-

vation process is successful, the dialog can be closed and 

BIMCalc will switch to an activated state, lifting up the trial limitations. 
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3.3 Help -> Check for updates 

BIMCalc features an automatic updating procedure. At every start the application will check for a 

newer version. If available, a dialog will be presented to you listing the new features and the option 

to download and install the updates. BIMCalc will try to download and install the update manually, 

however, depending on your current Windows installation, settings, current BIMCalc projects, the 

automatic installation might not start. You can manually download the installer package from this 

same dialog and start the installation procedure at your convenience at a later date. 

2.2. Project management 

 

 

The project management bar can be found below the menu bar. The bar contains the following fea-

tures: 

1. New project 

2. Open existing project 

3. Save project 

4. Close project 

5. Import IFC model into project 

6. Compare imported IFC elements in the project 

7. Add remark for the currently selected IFC model element 

8. Create a printable PDF report of the remarks in the project 

1. New project 

Clicking this button will present you with a file saving dialog where you can select where you want 

to create a new BIMCalc project (.bmc file format). If you already have an opened BIMCalc project 

when you want to create a new one, BIMCalc will warn you that the existing project will be closed 

and offers you the option to save or discard changes made to that project before closing it and 

opening the new one. Please note that the BIMCalc Trial Edition will not save the project file to the 

desired location since project saving is disabled. 

2. Open project 

Clicking this button will present you with a file opening dialog where you can select the location of 

an existing BIMCalc project (.bmc file format). If you already have an opened BIMCalc project when 

you want to open a new one, BIMCalc will warn you that the existing project will be closed and of-

fers you the option to save or discard changes made to that project before closing it and opening 

the new one. 

After opening the project, BIMCalc will open the most recently opened IFC model from the BIMCalc 

project (or the first IFC model if this is the first opening). All other components of the main layout 

will change it’s contents based on this new IFC model opening. The 3D model viewer will also dis-

play the 3D representation of the selected IFC model. 
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3. Save project 

Clicking this button will save the current BIMCalc project to the selected location. A progress dialog 

will be presented to you which will show the progress of saving the project. The progress dialog will 

be automatically closed when the saving process finishes. Please note that depending on how many 

IFC models are imported to a project (and their file size), it can have a large impact on the time it 

takes to save the BIMCalc project file. Please wait out the progress patiently. Please note that the 

BIMCalc Trial Edition will not allow you to save your project. 

Tip: If in the title of the BIMCalc product window, you see an asterisk (*) after the BIMCalc project 

file name, that means that the project has unsaved changes. 

4. Close project 

Clicking this button will close the currently opened project. If the project has unsaved changes, 

BIMCalc will present you the option to save or discard these changes before closing the project. 

5. Import 

Clicking this button will present you with a dialog where you can select and import and IFC file into 

your BIMCalc project. The import dialog will ask you some information about the IFC model, such 

as: 

 

 

 

1. The location of the IFC model on your computer. You can click the ‘Browse’ button to be pre-

sented with a file opening dialog where you can browse to and select your IFC model file. 

2. The branch of your IFC model. A branch in essence is a collection of different versions of the 

same IFC model. You can select and existing branch in the project by clicking the arrow on the 

right of the input field, or you can freely specify a new one. 

3. The display name of this IFC model. If you already selected and IFC model file, the name of that 

file will be pre-filled in this input field. 
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4. The version of this IFC model file. You can freely choose between using numbers or text to fol-

low the versions of your IFC model files. 

5. The date of the IFC model. If you already selected an IFC model file, the creation date of the 

IFC model will be pre-filled in this input field (either the creation date from the IFC protocol, or 

the creation date of the file). If you want to modify this, you can click the arrow on the right 

side to open up a date picker to choose a different date. 

All fields are mandatory to import an IFC. If every field is specified and and IFC file is selected, click-

ing the ‘Import’ button will start the import procedure. A progress dialog will be presented to you 

which tracks the progress of the import process. During this process other features are not useable. 

Please note that depending on the complexity and file size of the IFC model file, the importing pro-

cess can take a while. Please wait patiently while the process is being done. If the process is com-

pleted, the progress dialog will automatically close and the IFC model will be displayed in the 3D 

model viewer. If this was your first import into the new BIMCalc project, a new dialog will also be 

presented to you, asking whether you want to import an additional IFC model into the project. 

Confirming the dialog will guide you through the same import process as described above. 

Please note that the BIMCalc Trial Edition will only allow you to import 2 IFC model files into a pro-

ject. 

6. Compare 

Clicking this button while at least two IFC model files are imported into the current project will pre-

sent you with a dropdown where you can select the target IFC model which will be compared to the 

currently opened IFC model. Selecting the target IFC model from this list will start the comparing 

procedure between the two IFC models. 

 

 

 

The comparison feature will be described in detail in the IFC model comparison section. 

7. Add Remark 

While there is an opened IFC model in your BIMCalc project and there is a currently selected IFC 

model element in the 3D model viewer, you can click this button to add a remark to this IFC model 

element. The remark feature will be described in the Project remarks section. 

8. Print 

Clicking this button will allow you to create a printable PDF document containing all the remarks in 

your BIMCalc project, covered in section 2. Print remark document. 
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2.3. Project Item Tree 

The project item tree can be found on the left side of the BIMCalc main layout. This section of the 

main layout displays your imported IFC models in the currently opened BIMCalc project in a tree-

like structure. 

 

 

 

The root elements of the tree will be your branches created in the project. The child IFC models of a 

branch can be seen below the branch name. The branch can be opened or collapsed by clicking the 

arrow on the left side of the branch name. 

Double clicking a row representing a branch will open or collapse that tree element. Right clicking a 

row will open a context menu where a number of features are available for a branch: 

• Import IFC: This will start a new import procedure as per the flow described above. 

• Delete branch: After a confirmation dialog, the branch and its child IFC models will be removed 

from the project. 

The names of the IFC models, their version and their date can be seen below the branch name. 

Double clicking a row representing an IFC model will open that IFC model. All other components of 

the main layout will change its contents based on this new IFC model opening. The 3D model vie-

wer will also display the 3D representation of the selected IFC model. Right clicking a row will open 

a context menu where a number of features are available for an IFC model: 

• Display item: Opening the IFC model can be achieved this way as well as double clicking a row. 

• Delete item: After a confirmation dialog, the IFC model will be removed from the project. 

• Compare this item: This will start a comparison procedure which will compare this selected IFC 

model with the currently opened IFC model. The comparison feature is described in the IFC 

model comparison section. 

2.4. IFC model element tree 

The IFC model element tree can be found on the bottom left corner of the BIMCalc main layout. 

This section of the main layout displays all IFC model elements contained in the currently displayed 

IFC model as a tree-like hierarchical structure. 

In the IFC protocol every element can have one other related element to it. This is represented as a 

tree in this structure. Usually the root elements of the tree are IFC element types which hold other 

elements together, such as sites, buildings, building floors, spaces, etc. Also, the IFC model element 

tree groups same element types together which are located inside one container element into a 

single tree element. In these cases, the name of the element in the tree will be the IFC protocol type 

name (such as IfcWallStandardCase for wall elements). 
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Clicking an element in this tree will select this element in all other related main layout sections (IFC 

model element table, IFC Model element properties). If the selected element has visible graphics in 

the 3D model viewer, it will be also selected and highlighted with a blue color. 

Double clicking a root element in the tree will collapse or show the child elements of that element. 

Double clicking a child element, if it has visible graphics in the 3D model viewer, will issue an at-

tempt to rotate the camera to an angle where the double clicked element is visible. If at this point 

there is another double click on the same element, it will issue an attempt to hide all visible 

graphics until the selected element is clearly visible. Tip: After this state, if you want to return to the 

default state of the 3D model viewer, use the 2.1 View -> Reset View menu item or it’s shortcut. 

A checkbox is located on the left side of every element in the tree. This is a visual control indicator 

and switcher in the 3D model viewer. Unchecking a checkbox next to a child element in the tree will 

prevent that element from rendering in the 3D model viewer. Unchecking a checkbox next to a root 

element in the tree will prevent all child elements from rendering in the 3D model viewer. Every 

check and uncheck in the tree will cause a graphical redraw in the 3D model viewer, which, depend-

ing on the size and complexity of the displayed IFC model, could take a while. A progress windows 

is displayed until the changes are being made inside the 3D model viewer. Tip: The 2.1 View -> Re-

set View menu item will not revert the elements into a checked state. These have to be manually re-

checked in the IFC model element tree. 

2.5. IFC model element table 

The IFC model element table can be found on the bottom of the BIMCalc main layout. This section 

has to tab items on the top: 

1. Grid View 

2. Comparison View 

1. Grid View 

The top section of the grid view contains area calculation related components, while the bottom 

section of the grid view contains a data table which lists all IFC model elements in the currently 

opened IFC model (similarly to the IFC model element tree, but without hierarchy). 
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Clicking an entry in the data table will select the element in the data table and in all other related 

main layout sections (IFC model element tree, IFC Model element properties). If the selected ele-

ment has visible graphics in the 3D model viewer, it will be also selected and highlighted with a 

blue color. 

It is also possible to click the headers of the data table. Clicking a header will order the data table 

by that header. Multiple clicks change the ordering between ascending and descending. An input 

field is available below some of the headers. These are filtering input fields. Typing a value to one 

of these text boxes will filter the table based on the typed value after a delay. The filtered data table 

has an additional feature. The IFC model elements which got excluded from the data table by the 

filtering will be displayed in a transparent color in the 3D model viewer. Until this graphical redra-

wing takes effect, a progress dialog will be presented to you, which will automatically disappear 

when the progress is completed. Similarly to this, for the ‘Type’ column in the data table, a drop-

down is available instead of a text box. Opening the dropdown will present you a list of all available 

IFC element types in the currently opened IFC model. Selecting a type in this dropdown will filter 

the data table so that only those elements are displayed which have the selected type. Tip: to return 

the data table to its unfiltered state, remove the text from the input fields, and select the ‘All’ option 

for the ‘Type’ dropdown filter. 

The first two columns of the data table, and the top section of the grid view contains area calcula-

tion features. Clicking an element in the data table, or clicking an element in the 3D model viewer, 

will start a process of surface area calculation for the selected element. BIMCalc will try to retrieve 

the surface area information for the element first from the IFC model file itself, or if it is not present, 

it will try to calculate the surface area by estimating the graphical model dimensions calculated by 

the 3D graphical model engine. Please note that the latter is a hard estimation and might not be 

precise information. The calculated surface area is displayed for the selected element in the second 

column of the data table in square meters. 

The top right corner of the grid view contains a text field where the total area of the selected IFC 

model elements is displayed. To include an area into this sum, click the selected element in the data 

table, and in the dropdown located in the first column for the selected element, select ‘Include’. It is 

also possible to subtract the area of a given element from the calculation. To achieve this, select 

‘Subtract’ from the dropdown. If you do not want to include the area of an element into the calcu-

lation, revert the dropdown value back to ‘Exclude’. To reset the sum area value, you can click the 

‘Reset’ button located on the top center of the grid view. This will reset the state of all elements 

into ‘Exclude’ state and reset the sum value, but it will keep the calculated area information in the 

second column. 

A dropdown is presented to you on the top left corner of the grid view. There are a number of avai-

lable options in this dropdown which are essentially rules which will include a number of elements 

file:///C:/Users/a.vonk/AppData/Local/Microsoft/Windows/INetCache/Content.Outlook/YQ063TKN/Quickstart.docx%23Xbb57efdbec6eaaa26215d3a5e7e4457ae708e78
file:///C:/Users/a.vonk/AppData/Local/Microsoft/Windows/INetCache/Content.Outlook/YQ063TKN/Quickstart.docx%23Xbb57efdbec6eaaa26215d3a5e7e4457ae708e78
file:///C:/Users/a.vonk/AppData/Local/Microsoft/Windows/INetCache/Content.Outlook/YQ063TKN/Quickstart.docx%23Xbb57efdbec6eaaa26215d3a5e7e4457ae708e78
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in the data table into the area sum calculation. Selecting an option in the dropdown and clicking 

‘Calculate’ will calculate the area information of all elements which match the rule, include them in 

the selection by setting their first column dropdown to ‘Include’. Additionally, all elements which 

are excluded by the rule will have their first column dropdown set to ‘Exclude’, and they will be pre-

sented in a transparent color in the 3D model viewer. While this process is taking place, a progress 

modal will be presented to you, which will automatically disappear once the process is done. To re-

set the sum area value calculated by this process, you can click the ‘Reset’ button located on the 

top center of the grid view. This will reset the state of all elements into ‘Exclude’ state and reset the 

sum value, but it will keep the calculated area information in the second column. 

The available options in the dropdown should be self explanatory, but from the technical point of 

view, the following rule is matched to the data table for the specific options: 

• First floor slab elements: All IfcSlab type IFC elements which are located in the first hierarchi-

cally available IfcBuildingStorey element. 

• All floor slab elements: All IfcSlab type IFC elements. 

• Roof slab elements: All IfcRoof type IFC elements. If none are found, then all IfcSlab type IFC 

elements which are located in the last hierarchically available IfcBuildingStorey element. 

• Facade elements: All IfcWallStandardCase type IFC elements. 

• All window elements: All IfcWindow type IFC elements. 

• All door elements: All IfcDoor type IFC elements. 

Please note that these rules are suggestions which should help you in calculating different sum val-

ues for the IFC model. The displayed sum value for these rules should be manually overseen and 

corrected by using the ‘Include’, ‘Exclude’ and ‘Subtract’ first column options in the data table. 

There is no programmatically perfect automatic way of calculating required dimensions for IFC 

models, therefore BIMCalc aims to give features which help and fasten the manual work needed to 

calculate these. 

Tip: An example approach on how to calculate ground surface area for an IFC model (Example 1). - 

From the bottom left IFC model element tree section of the BIMCalc layout, locate the first building 

storey tree element. - From the storey tree element, locate the next tree element called IfcSlab, 

which bundles up all IfcSlab type IFC elements on the first building storey. - Click through the 

IfcSlab child elements of the tree element. Clicking an entry here will automatically select the entry 

in the grid view data table and will also automatically calculate its area value. Oversee the element 

highlighted in blue in the 3D model viewer. If this element should be part of the ground surface 

area calculation based on your decision, select the ‘Include’ option for the element in the first co-

lumn of the grid view data table. - Follow this procedure for every child element. - This approach is 

useful for buildings where the ground surface area can be calculated based on the first floor IfcSlab 

element area values. 

Tip: An example approach on how to calculate ground surface area for an IFC model (Example 2). - 

In the IFC model element table section, on the grid view tab, select the ‘All floor slab elements’ op-

tion from the rule dropdown and click ‘Calculate’. This will calculate the are values of all IfcSlab type 

IFC elements in the IFC model. - Once the process is done, click ‘Reset’ next to ‘Calculate’ in the grid 

view to reset the area calculation sum value. This will not remove the area values calculated for the 

elements. - For the ‘Type’ column filter dropdown located below the data table column header in 

the grid view, select the ‘IfcSlab’ option. This will filter down the data table to only show the IfcSlab 
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elements. - Click the ‘Area’ column header in the data table in the grid view two times. This will or-

der the table based on the calculated area values in descending order (highest first). - Start and 

click through the data table entries. Every selected item will be highlighted in blue color in the 3D 

viewer. If the element should be part of the ground surface area calculation based on your decision, 

select the ‘Include’ option for the element in the first column of the grid view data table (usually, 

the bigger IfcSlab elements are for sure need to be a part of the calculation, so this approach can 

provide a good estimate value in a matter of minutes). - This approach is useful for non-traditional 

building layouts or more complex IFC models. 

Tip: An example approach on how to calculate total surface area for an IFC model (Example 1). - In 

the IFC model element table section, on the grid view tab, select the ‘All floor slab elements’ option 

from the rule dropdown and click ‘Calculate’. This will calculate the are values of all IfcSlab type IFC 

elements in the IFC model. - Click the ‘Area’ column header in the data table in the grid view two 

times. This will order the table based on the calculated area values in descending order (highest 

first). - Start and click through the data table entries. Every selected item will be highlighted in blue 

color in the 3D viewer. Oversee the element in the 3D model viewer. If the element should not be 

part of the surface area calculation based on your decision (for example, duplicated element, or the 

element is outside of the building), select the ‘Exclude’ option for the element in the first column of 

the grid view data table. - This approach is useful for more traditional IFC elements where the sur-

face of every area can be calculated by just IfcSlab type IFC elements. 

Tip: An example approach on how to calculate total surface area for an IFC model (Example 2). - In 

the IFC model element table section, on the grid view tab, select the ‘All floor slab elements’ option 

from the rule dropdown and click ‘Calculate’. This will calculate the are values of all IfcSlab type IFC 

elements in the IFC model. - Once the process is done, click ‘Reset’ next to ‘Calculate’ in the grid 

view to reset the area calculation sum value. This will not remove the area values calculated for the 

elements. - For the ‘Type’ column filter dropdown located below the data table column header in 

the grid view, select the ‘IfcSlab’ option. This will filter down the data table to only show the IfcSlab 

elements. - Click the ‘Area’ column header in the data table in the grid view two times. This will or-

der the table based on the calculated area values in descending order (highest first). - Start and 

click through the data table entries. Every selected item will be highlighted in blue color in the 3D 

viewer. If the element should be part of the surface area calculation based on your decision, select 

the ‘Include’ option for the element in the first column of the grid view data table (usually, the big-

ger IfcSlab elements are for sure need to be a part of the calculation, so this approach can provide 

a good estimate value in a matter of minutes). - This approach is useful for non-traditional or more 

complex buildings. 

2.6. The Comparison element table 

The comparison feature and its components will be described in detail in the IFC model comparison 

section. 

2.7. IFC Model element properties 

The IFC model element properties section can be found on the top right corner of the BIMCalc 

main layout. This section provides in-depth technical and IFC protocol information for the currently 

selected IFC model element. 
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This section displays information for the currently selected IFC model element. This element can be 

selected from a range of different other components (IFC model element tree, IFC model element 

table, 3D model viewer). The displayed information is automatically refreshed if a new element is 

selected. The displayed information is grouped to separate tabs which are located on top of the 

properties section. Every information is read-only and is only available for information purposes, it 

can not be changed or removed. 

The ‘Verbose’ checkbox on the top of all tab items also display properties for the element which do 

not have a proper value. The arrow icons on the left side of every property group can be used to 

collapse or show the child properties of that group. 

2.8. Project remarks 

The project remarks section can be found on the bottom right corner of the BIMCalc main layout. 

This section allows you to add remarks to specific IFC model elements for the BIMCalc project. 

 

 

 

Three features are available on the top of this section: 

1. Add remark 

2. Print remark document 

3. Show or hide completed remarks 

1. Add remark 

To add a remark, first you have to select an element in any of the other main BIMCalc layout sec-

tions (IFC model element tree, IFC model element table, 3D model viewer). After selecting an ele-

ment, click the ‘Add remark’ button represented with a ‘Plus’ icon to add a remark to that element. 
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A text area will appear below the button where the remark comment can be added. Please note 

that the 3D model viewer changes its camera position to where the selected element is clearly visi-

ble and all other elements are not visible. Before saving the remark, fine tune the camera to your 

wishes. At the time of accepting the remark, a picture will be taken which will be visible when you 

create a printable remark PDF. The remark can be saved by clicking the ‘Accept’ button, or can be 

cancelled by the ‘Cancel’ button. Both buttons will reset the 3D model viewer into its default state. 

The remark will be added under the username set for BIMCalc in the 1.8 File -> Settings menu 

point. 

Please note that while you can add remarks in the BIMCalc Trial Edition to try out the feature, you 

can not save the project, hence after closing the project, all remarks will be gone. 

2. Print remark document 

Clicking this button will allow you to create a printable PDF document containing all the remarks in 

your BIMCalc project. 

You will be presented with a file saving dialog where you can select to where you want to save this 

PDF document. You will be presented with a progress dialog while the PDF document is in the ma-

king. The progress dialog will automatically close when the process is finished. The PDF document 

can after be opened and printed by your preferred software. 

3. Show or hide completed remarks 

Checking this checkbox will hide remarks in the BIMCalc project which have been marked as com-

pleted. Remarks can be marked as completed by checking the checkbox located on the left side of 

the remark. 

4. Remark list 

The remarks are grouped by IFC model elements in a tree like structure. Multiple remarks can be 

added to the same element. Double clicking the root remark group element will collapse or show 

the remarks for that element. Right clicking the root remark group element will present you with a 

context menu where you can initiate adding a new remark to the selected IFC model element. 

The remark text contains the name of the user who added the remark, the date of the remark as 

well as it’s content. Clicking a remark will select the element which is marked with it in all other 

BIMCalc main layout components. Right clicking the remark will present you with a context menu 

containing: 

• Add a new remark to this element: Initiate adding a new remark to the selected IFC model ele-

ment. 

• Edit remark: Edit the contents of the remark. This option is only available to the user who origi-

nally created the remark. This will open up the same text area as when you would create a new 

one. The content of the remark can be changed there. 

• Delete remark: Deletes the selected remark. This option is only available to the user who origi-

nally created the remark. After a confirmation dialog, the remark can be deleted. 

A checkbox can be found on the left side of the remark. Checking this checkbox will mark this re-

mark as completed. The completion will be saved along inside the BIMCalc project (a project save is 

needed for it to stay permanent). 
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Please note that while you can mark remarks as completed in the BIMCalc Trial Edition to try out 

the feature, you cannot save the project, hence after closing the project, all remarks will be gone. 

If you were the original creator of the remark, a red ‘X’ icon will also be available to you on the left 

side. This is a shortcut to delete a remark, with the same functionality as described above. 

2.9. 3D model viewer 

The 3D model viewer can be found on the center of the main BIMCalc layout. This is a graphical 3D 

representation of the currently opened IFC model. 

 

 

 

The name of the currently viewed IFC model can be found on the top section of the 3D model vie-

wer. A coordination navigator can be found on the bottom left corner, while a directional navigator 

can be found on the bottom right corner. The sides of the directional navigator can be clicked. This 

will rotate the camera of the 3D viewer to the selected orientation. 

Operating the camera inside the 3D model viewer is done via mouse clicks and movements. Clic-

king and holding right click will rotate the camera around the point where the mouse click hap-

pened. Zooming in and out can be done using the mouse wheel. Pressing and holding the mouse 

wheel will move the camera without rotation. 

An IFC model element can also be selected in the 3D model viewer by pressing left click on it. This 

will highlight the selected element in blue color, and it will also select the element in all other main 

layout components (IFC model element tree, IFC model element table, IFC Model element proper-

ties). Quickly right clicking an IFC model element in the 3D viewer brings up a context menu with 

the ‘Hide selected element’ option. This will remove the graphical rendering of the element from 

the 3D viewer (this change is also reflected in the IFC model element tree - the corresponding 

checkbox will be unchecked). 

Since the camera movement is completely unrestricted in the 3D model viewer, it might happen 

that too much directional movement and rotation brings the camera into an inconvenient location. 
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To reset the camera to its default position, use the 2.1 View -> Reset View menu item, or its 

shortcut. 

Graphical redrawing processes initiated from any main components will display a progress dialog 

inside the 3D model viewer, and the 3D model viewer will be unresponsive while these processes 

are being done. The progress window will automatically close when the process is completed. 

Please note that complex or large IFC files can take a while to be graphically rendered, and it can 

also impact the performance of BIMCalc. The process and performance can be boosted by un-

checking unnecessarily rendered IFC elements using the 2.2 View -> Configure View menu item. 

3. BIMCalc main features 
3.1. IFC file importing and project management 

BIMCalc provides features to import IFC files into separate collections to create a project bundle 

containing all your related IFC files. These are managed by BIMCalc’s own file format. The applica-

tion also provides a 3D model viewer to visually render your IFC models, and it also provides fea-

ture to quickly swap between the imported IFC files. Structural, hierarchical and metadata infor-

mation on the elements inside the imported IFC file are all available across the main layout compo-

nents of BIMCalc. For IFC file importing and BIMCalc project management, visit the 5. Import and 

Project management sections. For information on the 3D model viewer, visit the 3D model viewer 

section. 

3.2. Area calculation 

BIMCalc provides features to calculate surface areas of IFC model elements in the imported IFC fi-

les, and it also provides features to help create area calculations for an IFC model. For a detailed 

guide, visit the 1. Grid View section. 

3.3. IFC model comparison 

BIMCalc provides features to compare different versions of the same IFC models together. Project 

management provides you with tools to add these IFC models into the same branch. Please note 

that the comparison feature is not available in BIMCalc Trial Edition. 

The project comparison always compares the currently opened IFC model with a target IFC model. 

The process can be started by two different ways: 

• In the Project Item Tree, right click the IFC model which you want to compare the current 

model with. 

• In the Application menu bar, click the 6. Compare button and select the target IFC model which 

you want to compare the current model with. 

A progress dialog will be presented to you when the process starts and it will be visible until the 

comparison completes. After the comparison is done, the following changes will happen inside 

BIMCalc: 

• You will still see the graphical representation of the currently opened IFC model, but the follo-

wing changes will be applied to it: 
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o If an IFC model element is unchanged between the two compared IFC models, the element 

will be rendered in a transparent color. 

o If an IFC model element has been modified between the two compared IFC models, the 

element will be highlighted with a purple color. 

o If an IFC model element is missing in the target IFC element, it will be highlighted with a 

red color. 

o If an IFC model element has been newly added in the currently displayed IFC model (e.g. is 

missing in the target IFC model), it will be highlighted with a green color. 

• The title of the 3D model viewer will represent the names and comparison direction of the two 

IFC models. 

• The IFC model element table will switch to the Comparison view. 

The functionality of the main layout components will stay the same, so IFC model elements can be 

selected from any main layout components after the comparison. 

1. Comparison view 

While in the 3D model viewer you can view the graphical result of the comparison, the Comparison 

view in the IFC model element table will contain the metadata information about the IFC model ele-

ments which are either modified, missing, or has been newly added to the current IFC model. 

 

 

 

The top section of the Comparison view contain a data table containing the elements relevant for 

comparison. Clicking an entry in the data table will select the element in the data table and in all 

other related main layout sections (IFC model element tree, IFC Model element properties). If the 

selected element has visible graphics in the 3D model viewer, it will be also selected and high-

lighted with a blue color. 

It is also possible to click the headers of the data table. Clicking a header will order the data table 

by that header. Multiple clicks change the ordering between ascending and descending. An input 

field is available below some of the headers. These are filtering input fields. Typing a value to one 

of these text boxes will filter the table based on the typed value after a delay. The filtered data table 

has an additional feature. The IFC model elements which got excluded from the data table by the 

filtering will be displayed in a transparent color in the 3D model viewer. Until this graphical redra-

wing takes effect, a progress dialog will be presented to you, which will automatically disappear 

when the progress is completed. Similarly to this, for the ‘Type’ and ‘Comparison Result’ columns in 

the data table, a dropdown is available instead of a text box. Opening the dropdown will present 

you a list of all available IFC element types in the currently opened IFC model, or comparison result 

types after the comparison. Selecting a type or result in these dropdowns will filter the data table so 

that only those elements are displayed which have the selected type or result. Tip: to return the 
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data table to its unfiltered state, remove the text from the input fields, and select the ‘All’ option for 

the ‘Type’ and ‘Comparison result’ dropdown filters. 

Two buttons are available on the top of the data table: 

1. Compare: If a row is selected in the data table, a new dialog will be presented to you, which 

contains the metadata information for the selected IFC model element in both the current and 

the target IFC model. The two sections are in essence two copies of the IFC Model element 

properties section. The left side is the original metadata, while the right side is the metadata of 

the element inside the target IFC model. If the metadata is not present for one of the IFC mo-

dels (i.e. the element has been removed or newly added), the section will be empty. Clicking 

any tab pages in ether of the sections will automatically switch the other section tab item as 

well. 

2. Show: If a row is selected in the data table, then the camera inside the 3D model viewer will 

switch to a position where the IFC model element relevant to the selected row is clearly visible. 

Other IFC model elements are only displayed in a minimal fashion to achieve this. If the related 

IFC model element is not available in the currently displayed IFC model, a dialog will be pre-

sented to you informing you about this. A yellow information row on top of the 3D model vie-

wer will also be presented to you informing you about this current camera position change. 

Closing the information row with the ‘X’ icon on the top right will revert the camera to its previ-

ous state. 

2. Comparison Example 

In this comparison example we will compare two very basic IFC models, a room with four walls and 

one window. One version of the room contains a smaller separation wall in the middle, while from 

the other IFC model, this has been removed. 

 

 

Version ‘2’ of this IFC model has the separation wall inside. 
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Version ‘1’ of this IFC model has this separation wall removed. 

Using BIMCalc’s comparison feature, we see the following result, comparing the two IFC models, 

while having version ‘2’ of the IFC model currently displayed: 

 

 

 

The 3D model viewer has changed all unaffected IFC model elements into a transparent color. The 

result of the comparison is, as expected, that the separation wall has been marked as ‘Missing’ in 

the data table of the Comparison view, and it has been highlighted in the 3D model viewer in a red 

color. 



 

 

 


